AppFolio Status Page - Credit Card Payment Processing Issues – Incident details

All systems operational

Credit Card Payment Processing Issues

Resolved
Partial outage
Started about 2 hours agoLasted about 2 hours

Affected

Payment Services

Partial outage from 5:45 PM to 7:18 PM

Credit Card Processing

Partial outage from 5:45 PM to 7:18 PM

Updates
  • Resolved
    Resolved

    Our processor re-processed all pending payments and confirmed that all processing attempts were successful. Tenants and homeowners whose payments were not immediately debited will see a debit to their account in the coming days.

  • Investigating
    Investigating

    We're currently aware of an issue impacting rent, dues, and owner contribution payments made via MasterCard. Payers who made a payment via the online portal or owner portal may not see a debit to their account.

    Our team is working diligently to resolve the issue as soon as possible, and will share updates on this page as they become available.