AppFolio Status Page - Request a Call Latency – Incident details

All systems operational

Request a Call Latency

Monitoring
Partial outage
Started 25 minutes ago

Affected

Customer Support

Partial outage from 9:46 PM to 9:53 PM, Operational from 9:53 PM to 12:00 AM

Request a Call

Partial outage from 9:46 PM to 9:53 PM, Operational from 9:53 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    Request a Call is now loading for the majority of users. We will continue to monitor the status of this channel to ensure that all issues are resolved.

  • Investigating
    Investigating

    We are currently experiencing an issue causing intermittent issues with scheduling a support call using Request a Call. We are urgently investigating the issue, but does not yet have an estimated resolution time. In the meantime, please contact our Customer Care team using alternate communication channels, including Live Chat, Contact Me Later, and the Dedicated Phone Line (for Plus and Max customers).