AppFolio Status Page - Screening Issues – Incident details

All systems operational

Screening Issues

Resolved
Degraded performance
Started 26 days agoLasted about 1 hour

Affected

Tenant Screening

Degraded performance from 2:20 PM to 3:05 PM

Income Verification

Degraded performance from 2:20 PM to 3:05 PM

Credit Reporting

Degraded performance from 2:20 PM to 3:05 PM

Core Tenant Screening

Degraded performance from 2:20 PM to 3:05 PM

Rental History

Degraded performance from 2:20 PM to 3:05 PM

Criminal Bulk File

Degraded performance from 2:20 PM to 3:05 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently experiencing issues with tenant screening, load times, ID & Income Verification, and reporting.

    Our team is working diligently to resolve the issue as soon as possible, and will share updates on this page as they become available.